A quick guide to UPnP on MikroTik Router OS

I’m sure there are vast amounts of write ups on this out there however I thought I’d add my 2p. UPnP is being used increasingly more to poke holes through firewall and NAT to allow services such as online gaming access to the wider world whilst retaining the “easy” aspect of not having to go for static LAN IP’s and port forwarding. Whilst forwarding (or dst-nat) is always preferable UPnP can be used as a “quick” fix to get that “open nat” setting.

To do it correctly within a MikroTik device you will need to use the following but slightly alter it to your use case. Note the external interface in my example is for a pppoe client, this could easily be changed to a hardware interface (such as ether1) and that the internal interface is bridge1, as a general guide line, external should be whatever interface your WAN IP resides and internal should be whichever interface your LAN IP resides.

/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=pppoe-out1 type=external
add interface=bridge1 type=internal